Documentation

The bare minimum that Data Pump requires to be able to run any of the simple scripts successfully is providing him with a source and a destination for the job whether it’s import, export or direct migration. Unless otherwise stated DataPump requires datasets to be uncompressed and complete. As far as the more complex scripts go (Collation and Union) the minimum requirements are described in their respective documentation.

Supported file formats:

  • ESRI Shapefile (shp)
  • MapInfo TAB (tab)
  • MapInfo Mid/Mif (mif)
  • OGC Geography Markup Language (gml)
  • Comma Separated Value textfile (csv)

Supported databases:

  • SQL Server 2005 and above
  • PostgreSQL with PostGIS module
  • Oracle 10g and above